Google has released a fix to address this issue. Users may have to update their Chrome browser to receive the update.
Posted May 22, 2025 - 11:27 PDT
Identified
Update from Google - the fix has been merged into release 137 - Early Stable Release is Wed, May 21, 2025.
Posted May 20, 2025 - 12:02 PDT
Investigating
ELEVATE Grouping Function Impacted by Chrome Update
A recent update made to Google’s Chrome Browser has caused an impact to the Grouping Functionality on ELEVATE Data Tables. A resolution from Google possible as early as next week but may take until June.
While waiting for the fix within Chrome it is possible to right click on the “Synced Status” button, located on the Time Interface Files administration tab, and select “Ungroup”. This will open visibility to all data and allow you to proceed with your tasks.